[visit-users] build_visit qt fails on mac OS 10.6

Mark Miller miller86 at llnl.gov
Tue Mar 30 19:35:37 EDT 2010


It looks like that is the case.

However, fear not. 1.12.2 is the last version of VisIt we've released on
Qt-3. The upcoming 2.0 release is on Qt-4 dot something.

Since you are using build_visit, you can obtain an updated copy of that
by using 

svn cat http://portal.nersc.gov/svn/visit/trunk/src/svn_bin/build_visit

Then, use 'build_visit --svn', set whatever database libs you want and
it should be ok.

Mark

On Tue, 2010-03-30 at 19:21 -0400, Brandt Belson wrote:
> Hello,
> I tried to install visit using the build_visit script on Mac OS X
> 10.6, but it failed while building Qt saying that this version of the
> OS is unsupported. Is it true that I can't install visit 1.12.2 on
> this OS? Here is the end of the build_visit_log file:
> 
> 
> Unzipping/Untarring Qt . . .
> Done with untar
> Patching Qt . . .
> patching file qt-mac-free-3.3.8/config.tests/mac/mac_version.test
> patching file qt-mac-free-3.3.8/include/qglobal.h
> patching file qt-mac-free-3.3.8/include/qt_mac.h
> patching file qt-mac-free-3.3.8/src/kernel/qcursor_mac.cpp
> patching file qt-mac-free-3.3.8/src/kernel/qt_mac.h
> patching file qt-mac-free-3.3.8/src/tools/qglobal.h
> Building Qt . . .
> Adding threading option
> 
> 
> This is the Qt/Mac Open Source Edition.
> 
> 
> You are licensed to use this software under the terms of
> the GNU General Public License (GPL).
> 
> 
> Type 'G' to view the GNU General Public License.
> Type 'yes' to accept this license offer.
> Type 'no' to decline this license offer.
> 
> 
> Do you accept the terms of the license? 
> Creating qmake. Please wait...
> c++ -c -o project.o -pipe  -DQT_MACOSX_VERSION= -I. -Igenerators -
> Igenerators/unix -Igenerators/win32 -Igenerators/mac -
> I/home/bbelson/visit/qt-mac-free-3.3.8/include/qmake -
> I/home/bbelson/visit/qt-mac-free-3.3.8/include -
> I/home/bbelson/visit/qt-mac-free-3.3.8/include -DQT_NO_TEXTCODEC -
> DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_STL -DQT_NO_COMPRESS -
> I/home/bbelson/visit/qt-mac-free-3.3.8/mkspecs/macx-g++ -
> DHAVE_QCONFIG_CPP project.cpp
> In file included from /home/bbelson/visit/qt-mac-
> free-3.3.8/include/qtl.h:42,
>                  from /home/bbelson/visit/qt-mac-
> free-3.3.8/include/qvaluelist.h:42,
>                  from /home/bbelson/visit/qt-mac-
> free-3.3.8/include/qstringlist.h:42,
>                  from project.h:39,
>                  from project.cpp:36:
> /home/bbelson/visit/qt-mac-free-3.3.8/include/qglobal.h:190:6: error:
> #error "This version of Mac OS X is unsupported"
> project.cpp: In member function 'bool QMakeProject::read(uchar)':
> project.cpp:685: warning: format not a string literal and no format
> arguments
> make: *** [project.o] Error 1
> qmake failed to build. Aborting.
> Qt configure did not find OpenGL. VisIt needs Qt with enabled OpenGL
> support. Giving up.
> 
> 
> Thanks
> --
> List subscription information: https://*email.ornl.gov/mailman/listinfo/visit-users
> Searchable list archives: https://*email.ornl.gov/pipermail/visit-users
> VisIt Users Wiki: http://*visitusers.org/
> Frequently Asked Questions for VisIt: http://*visit.llnl.gov/FAQ.html
> 
-- 
Mark C. Miller, Lawrence Livermore National Laboratory
================!!LLNL BUSINESS ONLY!!================
miller86 at llnl.gov      urgent: miller86 at pager.llnl.gov
T:8-6 (925)-423-5901    M/W/Th:7-12,2-7 (530)-753-8511



More information about the visit-users mailing list