[visit-users] Remote Visualization

Meredith, Jeremy S. jsmeredith at ornl.gov
Wed Mar 10 21:11:40 EST 2010


Hmm...   that's odd, then.  No, there shouldn't be any required compatibility between local and remote.

My best guess offhand is that something might be happening where an interactive login gets a different environment than a non-interactive login.  For example, if you have a dot file (e.g. .profile or .cshrc) which sets up a module which sets an LD_LIBRARY_PATH, then this might get triggered in one case but not in another.

You might be able to diagnose this, or at least get some helpful information, by using non-interactive logins to set it.  E.g "ssh orthanc env" would print the environment you get in the latter case, and "ssh othanc" (login and wait for prompt) followed by "env" would get the environment in the former case.

--
Jeremy Meredith
Oak Ridge National Laboratory

From: Mosher, Scott W. [mailto:moshersw at ornl.gov]
Sent: Wednesday, March 10, 2010 6:31 PM
To: VisIt software users community
Subject: Re: [visit-users] Remote Visualization

Jeremy,

The machine is orthanc.ornl.gov - it's a small Linux cluster (16 dual quad core nodes) owned by our group (I work in NSTD).

>From my Windows machine, I can log into orthanc using X-Win32 and start VisIt just fine (I just did to confirm). Of course, it is painfully slow to pump the graphics across the network.

Is there some sort of required compatibility between the shared libraries running on the local and remote machines?

Scott


From: Meredith, Jeremy S. [mailto:jsmeredith at ornl.gov]
Sent: Wednesday, March 10, 2010 6:16 PM
To: VisIt software users community
Subject: Re: [visit-users] Remote Visualization

I was just thinking I should add a little more info here.  First, I'm assuming this is one of the ORNL clusters that we have access to.  Obviously if not, we'll have to figure out an alternative.    Also, this doesn't look like a problem specific to trying to connect remotely -- in other words, I'm assuming if you SSH to this cluster and try to run visit on the login node, you'd get the same error.

--
Jeremy Meredith
Oak Ridge National Laboratory

From: Meredith, Jeremy S. [mailto:jsmeredith at ornl.gov]
Sent: Wednesday, March 10, 2010 6:08 PM
To: VisIt software users community
Subject: Re: [visit-users] Remote Visualization

Which cluster is this?  Maybe something changed we need to look at.

--
Jeremy Meredith
Oak Ridge National Laboratory

From: Mosher, Scott W. [mailto:moshersw at ornl.gov]
Sent: Wednesday, March 10, 2010 5:33 PM
To: visit-users at email.ornl.gov
Subject: [visit-users] Remote Visualization

Hi,

I'm having a problem getting remote visualization to work from my Windows PC to a Linux cluster. The cluster is running VisIt 1.12.1 and is used for remote viz by several of my colleagues, but always from Linux or Mac OS.

I set up the host profile with the name of the machine and set the `-dir` option to where VisIt lives, but when I select the remote host in the "Open File..." dialog I never get past the "metadata server launch progress" window (with the scrolling dots). I never get a password prompt. In the command prompt on my Windows box are the messages:

Running: vcl1.12.1 -host localhost visit visit -dir /usr/local/src/visit -noloopback -timeout 480 -dir /usr/local/src/visit -sshtunneling -port 35746 -launchengine localhost -engineargs ;-par
/usr/local/src/visit/1.12.1/linux-x86_64/bin/vcl: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/local/src/visit/1.12.1/linux-x86_64/bin/vcl)
/usr/local/src/visit/1.12.1/linux-x86_64/bin/vcl: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/local/src/visit/1.12.1/linux-x86_64/lib/libstate.so)
/usr/local/src/visit/1.12.1/linux-x86_64/bin/vcl: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/local/src/visit/1.12.1/linux-x86_64/lib/libcomm.so)
/usr/local/src/visit/1.12.1/linux-x86_64/bin/vcl: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/local/src/visit/1.12.1/linux-x86_64/lib/libmisc.so)
/usr/local/src/visit/1.12.1/linux-x86_64/bin/vcl: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/local/src/visit/1.12.1/linux-x86_64/lib/libutility.so)

Is this something that should be possible?

Any help is greatly appreciated!
Scott

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://email.ornl.gov/pipermail/visit-users/attachments/20100310/370d819b/attachment.html>


More information about the visit-users mailing list