[visit-users] Building visit on mac ox 10.5

Cyrus Harrison cyglor at gmail.com
Tue Mar 9 00:50:10 EST 2010


Hi Scott,
We are using Python 2.6.4 on OSX for our trunk development.
-Cyrus

On Mon, Mar 8, 2010 at 8:14 PM, Scott Baden <baden at cs.ucsd.edu> wrote:
> Hi, I had to download cmake-2.8.0.tar.gz manually. There was no version of
> cmake-2.8.0.tar.gz availble
> from the server.
>
>> Checking for files . . .
>> Checking for cmake-2.8.0
>> Downloading cmake-2.8.0.tar.gz . . .
>> Download attempt failed:
>> https://wci.llnl.gov/codes/visit/3rd_party/cmake-2.8.0.tar.gz
>> Download attempt failed:
>> https://wci.llnl.gov/codes/visit/3rd_party/cmake-2.8.0.tar.gz
>> Failed to download cmake-2.8.0.tar.gz
>
>
> Now I have another problem of the same sort, this time with python.
>
>> python-2.5
>> Downloading Python-2.5.tgz . . .
>> Download succeeded:
>> https://wci.llnl.gov/codes/visit/3rd_party/Python-2.5.tgz
>> ...
>> creating Modules/Setup
>> creating Modules/Setup.local
>> creating Makefile
>> gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp
>> -mno-fused-madd -DNDEBUG -O2 -fno-common -fexceptions  -I. -I./Include
>> -DPy_BUILD_CORE -o Modules/python.o ./Modules/python.c
>> cc1: error: unrecognized command line option "-Wno-long-double"
>> make: *** [Modules/python.o] Error 1
>
> Which version of python should I download?
>
> Scott
> On Mar 8, 2010, at 10:17 AM, Brad Whitlock wrote:
>
>> I assume you were using build_visit to start going through the VisIt build
>> process. The build_visit script tries to build cmake so it can later build
>> VTK. I see no reference to -Wno-long-double in build_visit's directions to
>> build cmake so the problem must be in cmake's own build process. So, I'd
>> recommend trying to use a newer cmake (2.8.0) on your system before
>> continuing with the VisIt build process. This can be accomplished by
>> downloading newer cmake sources and changing the following variables in
>> build_visit to use 2.8.0 in place of 2.4.5:
>>
>> export CMAKE_FILE=${CMAKE_FILE:-"cmake-2.4.5.tar.gz"}
>> export CMAKE_VERSION=${CMAKE_VERSION:-"2.4.5"}
>> export CMAKE_BUILD_DIR=${CMAKE_BUILD_DIR:-"cmake-2.4.5"}
>>
>> In response to your gcc question, we use what we have. My Mac happens to
>> have gcc 4.0.1 and it is out of my control. On Linux, VisIt's trunk has been
>> tested and known to work with gcc versions all the way up to gcc 4.4.
>>
>> Brad
>>
>>> I encountered a build error, in Cmake,
>>> The trouble is that the gcc command line option "-Wno-long-double"
>>> is no longer accepted by gcc. I'm using 4.2.1 on MacOS 10.5 (see below)
>>>
>>> I see that you support only up to v. 4.0.1
>>> Do you have plans to support more recent versions of gcc?
>>>
>>> Scott Baden
>>> ----
>>>
>>>
>>>
>>> gcc -v
>>> Using built-in specs.
>>> Target: i686-apple-darwin9
>>> Configured with: /var/tmp/gcc_42/gcc_42-5566~1/src/configure
>>> --disable-checking --enable-werror --prefix=/usr --mandir=/usr/share/man
>>> --enable-languages=c,objc,c++,obj-c++
>>> --program-transform-name=/^[cg][^.-]*$/s/$/-4.2/ --with-slibdir=/usr/lib
>>> --build=i686-apple-darwin9 --with-gxx-include-dir=/usr/include/c++/4.0.0
>>> --host=i686-apple-darwin9 --target=i686-apple-darwin9
>>> Thread model: posix
>>> gcc version 4.2.1 (Apple Inc. build 5566)
>>>
>>>
>>> M [40]: uname -a
>>> Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009;
>>> root:xnu-1228.15.4~1/RELEASE_I386 i386
>>>
>>>
>>>
>>> ___________________________________
>>>
>>> Scott B. Baden, Professor
>>> Computer Science and Engineering Department
>>> University of California, San Diego
>>> http://*www-cse.ucsd.edu/~baden
>>>
>>> --
>>> List subscription information:
>>> https://*email.ornl.gov/mailman/listinfo/visit-users
>>> Searchable list archives: https://*email.ornl.gov/pipermail/visit-users
>>> VisIt Users Wiki: http://*visitusers.org/
>>> Frequently Asked Questions for VisIt: http://*visit.llnl.gov/FAQ.html
>>
>>
>> --
>> ======================================================================
>> Brad Whitlock                   Lawrence Livermore National Laboratory
>> whitlock2 at llnl.gov
>> (925)424-2614
>> ======================================================================
>> --
>> List subscription information:
>> https://email.ornl.gov/mailman/listinfo/visit-users
>> Searchable list archives: https://email.ornl.gov/pipermail/visit-users
>> VisIt Users Wiki: http://visitusers.org/
>> Frequently Asked Questions for VisIt: http://visit.llnl.gov/FAQ.html
>>
>
> ___________________________________
>
> Scott B. Baden, Professor
> Computer Science and Engineering Department
> University of California, San Diego
> http://www-cse.ucsd.edu/~baden
>
> --
> List subscription information:
> https://email.ornl.gov/mailman/listinfo/visit-users
> Searchable list archives: https://email.ornl.gov/pipermail/visit-users
> VisIt Users Wiki: http://visitusers.org/
> Frequently Asked Questions for VisIt: http://visit.llnl.gov/FAQ.html
>
>


More information about the visit-users mailing list