[visit-developers] The test suite run on surface failed

Miller, Mark C. miller86 at llnl.gov
Thu Feb 4 20:16:48 EST 2016


Ok, I can duplicate.

The problem does indeed appear to be convert tool on surface.

Try typing 'convert --help'. It takes *forever* to print help and then it takes *forever* to return the prompt.

Mark


From: Kathleen Biagas <biagas2 at llnl.gov<mailto:biagas2 at llnl.gov>>
Reply-To: "visit-developers at elist.ornl.gov<mailto:visit-developers at elist.ornl.gov>" <visit-developers at elist.ornl.gov<mailto:visit-developers at elist.ornl.gov>>
Date: Thursday, February 4, 2016 4:13 PM
To: "visit-developers at elist.ornl.gov<mailto:visit-developers at elist.ornl.gov>" <visit-developers at elist.ornl.gov<mailto:visit-developers at elist.ornl.gov>>
Cc: "visit-developers at ornl.gov<mailto:visit-developers at ornl.gov>" <visit-developers at ornl.gov<mailto:visit-developers at ornl.gov>>
Subject: Re: [visit-developers] The test suite run on surface failed

surface86{kbonnell}:which convert
/usr/local/bin/convert

surface86{kbonnell}:convert -help
Version: ImageMagick 6.9.1-1 Q16 x86_64 2015-04-07
http://www.imagemagick.org
Copyright: Copyright (C) 1999-2015 ImageMagick Studio
LLC
License:
http://www.imagemagick.org/script/license.php
Features: DPC
OpenMP
Delegates (built-in): bzlib fftw fontconfig freetype gslib jng jpeg lcms
lzma pangocairo png ps tiff x xml
zlib



On Fri, 2016-02-05 at 00:07 +0000, Miller, Mark C. wrote:
Ok, thanks for looking into this that far. Hmm. I looked at two things
really quickly.
      1. current timout we use for test completion is 600 seconds (10
         mins)
      2. historical behavior of length of time movie.py takes (~180
         seconds or 3 mins). FYI...t is the 4th longest test we
         currently run.
I was thinking that maybe it was just below 10 mins before and is now
just exceeding 10 mins. Nope, thats not it.
Do you have a sense of  whether 10 mins indeed probably did pass
between the time you started it and when it was killed? Or, might it
seemed to have been killed a lot quicker than 10 mins.
BTW, at this point in the test, VisIt is done and we're just running
VisIt python cli making system calls to convert.
Hmm, that does the command 'convert' resolve to on surface for you?
Mark
From: Kathleen Biagas <biagas2 at llnl.gov<mailto:biagas2 at llnl.gov>>
Reply-To: "visit-developers at elist.ornl.gov<mailto:visit-developers at elist.ornl.gov>"
<visit-developers at elist.ornl.gov<mailto:visit-developers at elist.ornl.gov>>
Date: Thursday, February 4, 2016 3:33 PM
To: "visit-developers at elist.ornl.gov<mailto:visit-developers at elist.ornl.gov>"
<visit-developers at elist.ornl.gov<mailto:visit-developers at elist.ornl.gov>>
Cc: "visit-developers at ornl.gov<mailto:visit-developers at ornl.gov>" <visit-developers at ornl.gov<mailto:visit-developers at ornl.gov>>
Subject: Re: [visit-developers] The test suite run on surface failed
         I ran the movie.py test manually on surface (from an mxterm)
         with
         --lessverbose argument.


         It times out during a section of image converts (here's the
         last bit of
         messages printed out):


         Running: visit_composite viewport.info
         /g/g16/kbonnell/Branches/test/_run/_hybrid_movie/test5_0033.bmp bmp
         Running: visit_composite viewport.info
         /g/g16/kbonnell/Branches/test/_run/_hybrid_movie/test5_0034.bmp bmp
         convert test5_0000.bmp test5_0000.png
         convert test5_0001.bmp test5_0001.png
         convert test5_0002.bmp test5_0002.png
         convert test5_0003.bmp test5_0003.png
         convert test5_0004.bmp test5_0004.png
         convert test5_0005.bmp test5_0005.png
         convert test5_0006.bmp test5_0006.png
         convert test5_0007.bmp test5_0007.png
         convert test5_0008.bmp test5_0008.png
         convert test5_0009.bmp test5_0009.png
         convert test5_0010.bmp test5_0010.png
         convert test5_0011.bmp test5_0011.png
         convert test5_0012.bmp test5_0012.png
         <Limit
         killed> /g/g16/kbonnell/Branches/test/tests/hybrid/movie.py


         it happens even if I comment out everything but test 5 from
         movie.py,
         so something is making this test take much longer than it
         should (?)
         I also tried running from a login node on surface, same
         problem.  Funny
         thing though, when  I run it on my local linux box, no
         problems.


         Kathleen




         On Thu, 2016-02-04 at 16:47 +0000, Miller, Mark C. wrote:
                 Hmm. Looks like I may have botched the skip list
                 change I made
                 yesterday.


                 However, I looked at movie.py failure and am less sure
                 it is related
                 to something I've done.


                 Mark




                 From: "visit-developers at ornl.gov<mailto:visit-developers at ornl.gov>"
                 <visit-developers at ornl.gov<mailto:visit-developers at ornl.gov>>
                 Date: Thursday, February 4, 2016 6:04 AM
                 Subject: The test suite run on surface failed



                          The test suite run on surface failed.


                          The list of users who have modified VisIt
                 since the
                          test suite last succesfully PASSED or PASSED
                 w/SKIPS
                          is...


                          allen at sci.utah.edu<mailto:allen at sci.utah.edu>
                          bonnell2 at llnl.gov<mailto:bonnell2 at llnl.gov>
                          miller86 at llnl.gov<mailto:miller86 at llnl.gov>


                          The test suite results are at
                          http://portal.nersc.gov/project/visit/
















-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://elist.ornl.gov/pipermail/visit-developers/attachments/20160205/f6359f9d/attachment-0001.html>


More information about the visit-developers mailing list