[visit-developers] BoxLib fortran compiler

Mark Miller miller86 at llnl.gov
Mon Oct 6 17:46:30 EDT 2008


Hi Tom,

Any way to make the code that invokes 'gfortran' in build_visit
conditional on the version of the compiler or, alternatively, if g77
does not exist and gfortran does, use the latter?

I think -fPIC is needed when building any .o's that are later going to
be archived into a .a file and then used to build shared objects. I am
surprised you are just hitthing this now. First time using boxlib?

Mark

On Mon, 2008-10-06 at 15:44 -0600, tom fogal wrote:
> Hi all,
> 
> On a few machines now, I've had issues getting build_visit to get
> through building BoxLib.  Turns out the issue is that most modern
> Linux distributions have moved to gcc4, which uses the `gfortran'
> fortran compiler instead of the `g77' compiler.
> 
> An unrelated issue is that I need `-fPIC' in my cxxflags for my
> current main workstation.
> 
> Attached is a patch which changes both of these.  I ask whether this
> is okay pre-commit because it will *break* build_visit for BoxLib
> users which have g77 but not gfortran.
> 
> Any other review is welcome too, of course.
> 
> Thanks,
> 
> -tom
> 
-- 
Mark C. Miller, Lawrence Livermore National Laboratory
email: mailto:miller86 at llnl.gov
(M/T/W) (925)-423-5901 (!!LLNL BUSINESS ONLY!!)
(Th/F)  (530)-753-8511 (!!LLNL BUSINESS ONLY!!)



More information about the visit-developers mailing list